The identifier [default] is not a valid Java identifier as required by section 1.19 解决方法

新买一台笔记本,在windows中安装最新版Tomcat7,打开之前的项目神器的事情发生了。因为之前我可以保证项目可以正常运行,但是到目前最新Tomcat7最新版中无法运行,错误信息提示如下:

javax.el.ELException: The identifier [default] is not a valid Java identifier as required by section 1.19 of the EL specification (Identifier ::= Java language identifier). This check can be disabled by setting the system property org.apache.el.parser.SKIP_IDENTIFIER_CHECK to true.


再说下系统环境:
OS:win7.x64bit
JDK:jdk1.6.0_43
Tomcat:apache-tomcat-7.0.59-x86

通过Goolge搜索得知,这是Tomcat7对El中语法进行更严格的检查,之前的Tomcat版本因为没有这么如此严格的检查,所有项目中没有报这个错误。下次写代码时也要留心,不要用不严谨的写法了。这次就按照Tomcat介绍的方法,设置“org.apache.el.parser.SKIP_IDENTIFIER_CHECK = true”

解决方法:
在%CATALINA_BASE%\conf\catalina.properties中最后一行增加

org.apache.el.parser.SKIP_IDENTIFIER_CHECK=true

重启Tomcat,问题解决;

发表评论